Asset Resources

I am working on a iPaas flow that will remove all users, groups, and other select information from an asset when we are getting rid of the asset. 
I have been able to remove all unwanted attributes or change them for my purposes except for the users tab for the asset. 
I use the "Get Asset Resources" connector to get any user or account/department which is put in a list. I loop through the list then use the "Remove Resource From Asset" connector which works fine for the group but not the user.
When looking at the output for the "Get Asset Resources" the account/department gives back a 5 digit value while the user gives back the UID which gives the error "Bad Request ID: -1 Message: resourceID must be greater than 0."
I looked at the input data to which I dont see the UID of the user I see 0 for the resource ID.

Tags iPaaS
Asked by John Delgado on Mon 12/4/23 10:33 AM Last edited Mon 12/4/23 10:33 AM
Sign In to leave feedback or contribute an answer

Answer (1)

This answer has been marked as the accepted answer
Mark Sayers Mon 12/4/23 12:19 PM

Hello John,

When the resource ID will be a UID I believe you'd need to surround the value in quotes. It can't be a "naked" value for a string type property if it isn't a 100% integer value.

Mark Sayers
Sr Support Consultant, CS

0 of 1 users found this helpful.
Hello Mark,
Thank you for your answer and I tried that, It appears that the Resource ID needs to be an integer. When I tried to enter the UID in the Resource ID manually an error appeared saying it had to be an integer. Looking at the the remove button on the Users tab it appears to be using javascript to remove the user.
- John Delgado Mon 12/4/23 12:50 PM