Disabling SSL validation in iPaaS


I am trying to use Cisco's DNA Center APIs to create a connector. However, I keep getting hit with: "No such host is known." I tried the API calls in postman and it worked after disabling SSL validation. So I was trying to get that done in iPaaS. Is there someway to do that?

Tags SSL iPaaS
Asked by Mahir Rahman on Tue 6/7/22 2:59 PM
Update: The error I mentioned was a proxy issue. However, I get a new proxy error: Proxy Error: The SSL connection could not be established, see inner exception.::The remote certificate is invalid because of errors in the certificate chain: UntrustedRoot. I believe I still need to disable SSL for this one. - Mahir Rahman Wed 6/8/22 3:40 PM
Sign In to leave feedback or contribute an answer

Answer (1)

This answer has been marked as the accepted answer
Mark Sayers Wed 6/22/22 9:45 AM

Hello Mahir,

To "disable" SSL, use Http. If you're looking to still use the SSL protocol and ignore invalid certs (not trusted), we don't currently support this as its bad practice to do so. The solution is to either use a valid (trusted) cert or install the cert on the Proxy as a trusted cert.

No feedback