Question
- What happens if multiple people are editing a ticket simultaneously?
- What happens to ticket data if more than one person saves their edit on the same ticket at the same time?
- If two people post updates to the same ticket at the same time, what happens?
Environment
- TD Work Management with
- At least Technician level global access
- Application access to TDNext (Work Management) and the applicable Ticketing Application
Answer
If more than one person is editing a ticket at the same time, when they hit save, each of their edits will be applied completely, in the order they are received, and the changes from their previous value to their current value will be logged in the feed.
If two updates are made, the settings of those updates (including the public/private setting, and the notification settings) will honor what was selected by each respective technician.
Example (click image to enlarge):

In this example, "Kendra Technician" edited the ticket and clicked save slightly before "Jasnah Technician" and you can see that the values that Kendra changed the ticket to are the values that Jasnah's post say the values were changed from. Additionally, Jasnah did not edit the source field, so that field value remains with Kendra's value of "In-Person."
IMPORTANT: Because the Description field can be long, and tracking changes to it in the feed could take a lot of space, changes to the Description field are NOT logged in the ticketing feed.
Cause
TeamDynamix will alert technicians that other people are viewing (
), editing (
), or updating (
) the same ticket they are looking at, but the system does not lock the ticket to prevent simultaneous edits or updates.