What happens if multiple people edit a ticket at the same time?

Tags kcs

Question

  • What happens if multiple people are editing a ticket simultaneously?
  • What happens to ticket data if more than one person saves their edit on the same ticket at the same time?
  • If two people post updates to the same ticket at the same time, what happens?

Environment

  • TD Work Management with
    • At least Technician level global access
    • Application access to TDNext (Work Management) and the applicable Ticketing Application

Answer

If more than one person is editing a ticket at the same time, when they hit save, each of their edits will be applied completely, in the order they are received, and the changes from their previous value to their current value will be logged in the feed. 

If two updates are made, the settings of those updates (including the public/private setting, and the notification settings) will honor what was selected by each respective technician.

Example (click image to enlarge):

Screenshot from Work Management Ticketing feed showing one post by Jasnah Technician above another post from Kendra Technician.  The details of the changes in each post is described in the text below this image.

In this example, "Kendra Technician" edited the ticket and clicked save slightly before "Jasnah Technician" and you can see that the values that Kendra changed the ticket to are the values that Jasnah's post say the values were changed from.  Additionally, Jasnah did not edit the source field, so that field value remains with Kendra's value of "In-Person."

Cause

TeamDynamix will alert technicians that other people are viewing (A person icon next to the number 1 in dark green on a light green background), editing (A person icon next to the number 1 in dark red on a light red background), or updating (A person icon next to the number 1 in dark orange on a light orange background) the same ticket they are looking at, but the system does not lock the ticket to prevent simultaneous edits or updates.