How to enter new line in an email message

I have an iPaas flow that emails a list of successful transactions to a recipient.  The list is being generated in the flow as transactions are processed.  I have added an "alt-enter" (hold alt down and press enter key) at the end of each transaction.  This works when generating a text file, however, when the email is received the data is all on one line.  How do I go to a new line in the email message for each transaction?

Tags iPaas-Email-Newline
Asked by Michael Olson on Wed 1/24/24 9:38 AM
Sign In to leave feedback or contribute an answer

Answers (2)

This answer has been marked as the accepted answer
David Tod Wed 1/24/24 10:19 AM

Try triple brackets. It's a mustache thing.

In the Raw HTML view, it looks like this:


1 of 1 users found this helpful.
That did it! Thank you so much for your help! - Michael Olson Wed 1/24/24 10:41 AM

David Tod Wed 1/24/24 9:44 AM

Use a template, with the Email notification option and build it as HTML, i.e. with <br>. If you don't want that in the text line, add it through a replace function before sending the email.

Regex has worked for me (screenshot)

No feedback
Thanks - I had already tried adding a br and it isn't coming out on a new line. It doesn't make sense. - Michael Olson Wed 1/24/24 10:04 AM
I took a closer look at the actual email message html and the "<br />" is being replaced with /&lt;br /&gt. That isn't being processed by gmail as a newline. The data that I'm sending is being included in the template as a variable -there must be some process that replaces the <> with codes. Any idea how to bypass this? - Michael Olson Wed 1/24/24 10:08 AM