Users Import Job Question


Our import job for users had been running fine for quite a while until early December when it suddenly stopped. We can't figure out any reason as to why. We've tried restarting the server where the file TDX uses lives but that hasn't resolved the issue for us. Any assistance or ideas would be greatly appreciated.


Asked by Riley Fay on Tue 1/9/24 3:17 PM Last edited Tue 1/9/24 3:32 PM
Sign In to leave feedback or contribute an answer

Answer (1)

This answer has been marked as the accepted answer
Mark Sayers Tue 1/9/24 3:27 PM

Hi Riley,

Looks like your imports stopped submitting as of 12/9.

That is the same day that we warned, on 10/13, that the following changes would be going into effect regarding supported TLS cipher suites:


On 12/9/2023 we will be making several enhancements to connection security for inbound web connections to the TeamDynamix platform including:

  • Enabling TLS 1.3 with the following cipher suites
    • TLS_AES_128_GCM_SHA256
    • TLS_AES_256_GCM_SHA384
    • TLS_CHACHA20_POLY1305_SHA256
  • Disabling the following TLS 1.2 cipher suites

TLS 1.2 will still be available with the below cipher suites


These changes are available for testing in the TeamDynamix Release Preview Environment, which is now open.

A copy of this notification can be found in the Web Security Enhancements for TeamDynamix Applications KB Article.

No feedback
Hey Mark,

We made the changes on our end but our import is still not running correctly. This is what happens when we try to connect to upload the file:

C:\TeamDynamixSync>"C:\TeamDynamixSync\TeamDynamix.ApiUtility.PeopleImporter.exe" -u -b "45091D2B-3204-41A7-8362-74C8154688A6" -w "DDAD77D7-5EBB-4007-8186-07622F9B0C1B" -p "C:\TeamDynamixSync\Pending" -s "C:\TeamDynamixSync\Submitted" -f "C:\TeamDynamixSync\Failed" -n
INFO - Processing started.
INFO - Running in standard file-based processing mode.
INFO - Looking for pending import files to process in C:\TeamDynamixSync\Pending.
INFO - Found 1 pending file(s) to process.
INFO - Attempting admin authentication to the TeamDynamix Web API with API URL
ERROR - People importer encountered an error: One or more errors occurred.
- Riley Fay Thu 1/18/24 9:15 AM
Stack Trace: at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
at System.Threading.Tasks.Task`1.get_Result()
at TeamDynamix.ApiUtility.PeopleImporter.Helpers.TDApiHelpers.AdminAuthenticateAgainstTDApi(HttpClient apiClient, CommandLineOptions options)
at TeamDynamix.ApiUtility.PeopleImporter.Helpers.FileProcessingHelper.StartFileModeProcessing(CommandLineOptions options, Boolean fromDatabaseMode, String[] overrideFilePaths)
at TeamDynamix.ApiUtility.PeopleImporter.Program.Main(String[] args)
ERROR - Inner Exception details: An error occurred while sending the request.
INFO - Processing completed.

- Riley Fay Thu 1/18/24 9:15 AM
Is there a log file in the same directory of your server as the utility to show what might be happening to cause the error? If yes, you might need to start an official Support ticket with us (this is our public Questions system) to send that to us and allow us to review and help resolve it. - Mark Sayers Thu 1/18/24 9:44 AM
To confirm though, you verified that your server is now using a TLS cipher suite that we mentioned as being allowed currently? - Mark Sayers Thu 1/18/24 9:44 AM