I have a new form that does not allow workflow to be assigned.

 Assign workflow is not in the Actions list. It is a Public form.

Tags workflow
Asked by JAMES HOUSEHOLDER on Thu 8/3/23 8:13 AM
Sign In to leave feedback or contribute an answer

Answer (1)

This answer has been marked as the accepted answer
Brittany Renn Thu 8/3/23 8:57 AM

Hi James, 

In order for a workflow to be assigned, the requestor on the the ticket has to be an actual Customer/User record. If the Service is public, I would suggest editing the Service and choosing the "Requestor Matching Mode" for "Match using Email Address. If no requestor is found, create a new requestor and associate that record to the new ticket" on the Form tab. That should ensure that tickets created through that service always have a user record and then the workflow should apply. 


Brittany Renn

TDX Support

No feedback
Is there any way to have a public service that does not show user name and email address? That way we could have a default user in the form and use custom fields to get the user name and email. - JAMES HOUSEHOLDER Thu 8/3/23 9:33 AM
Unfortunately, I don't believe so. If "allow public requestors" is enabled, there will always be required fields for the requestor to provide their first name, last name, and email address - Brittany Renn Thu 8/3/23 9:37 AM