The specified username is in use. Please try another username.

Question

I am trying to create a user in TDAdmin, or running a People Import, and get the error "The specified username is in use. Please try another username." I checked, and I can't find another user in TDAdmin with the same username. Why am I getting an error that the username is in use, when there's no user in my environment with that username?

Environment

Answer

If you confirmed that the username is not in use within your own organization, then the username is in use at another organization. Adjust the username to be unique, ideally by adding your organization's domain at the end (e.g., cwillis@myorg.com).

Cause

You receive this error because you are a multi-tenant (non-Private Cloud) customer, and that username is in use by another multi-tenant customer.

When you are a multi-tenant customer, usernames must be unique among all other multi-tenant customers. For example, if an administrator at Organization A (who is multi-tenant) creates a user with username "cwillis", an administrator at Organization B (who is also multi-tenant) will get an error if they try to create a user with the username "cwillis", because that username is taken by Organization A.

This is why TeamDynamix suggests setting your users' usernames to something unique, unchanging, and including your organization's domain, such as ABC12345@myorg.com. Learn more in our related article on designing an SSO username strategy.

Learn more about multi-tenant vs Private Cloud in our related article on hosting options.

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Related Articles (2)

This article will describe how to utilize an immutable - or unchanging - username strategy when implementing SSO in TeamDynamix.
Learn more about the different hosting options for Work Management, including multi-tenant and private cloud.