Client Portal Image Not Found in Production after Sandbox Refresh

Tags kcs

Question

  • The banner image on our client portal is not displaying anymore
  • After the refresh, the images on our client portal broke
  • The image on our home page is missing

Environment

  • Administrative Access to the Client Portal:
    • Global TDAdmin Access OR
    • Client Portal Application Admin access

Answer

You'll need to re-upload the source image in Production:

  1. Access the Admin page for the Client Portal:
    1. Global admins: TDAdmin > Applications > Client Portal
    2. ​​​​​​​Application admins: Client Portal > Click your Name in the top right > Click Admin
  2. Click HTML Modules & Pages on the left
  3. Click HTML Modules on the left
  4. Click the Name of the Module you need to edit and use the editor to remove the old image and upload a new image

To avoid this issue over future Sandbox refreshes, upload images to Production first, then copy the HTML source code to Sandbox to view and test module configurations further in Sandbox.

Cause

If an image was uploaded into the Sandbox environment, and then the HTML source code was copied from Sandbox and pasted into Production, the image would display successfully until the next Sandbox refresh, because the URL generated for the image in Sandbox is still in place.  However, the Sandbox content is completely replaced by Production content during a refresh.  The link to the image will remain, and will reference the Sandbox URL, but the image it points to no longer exists.  By uploading the image to Production, the URL referencing that image will point to an image that continues to exist, even after the refresh.

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