Creating Knowledge Base Article Templates

Summary

Learn how to create and manage knowledge base article templates, including defining templates with HTML/Bootstrap formatting, organizing them into categories, and using pre-built template samples to maintain a consistent content structure.

Body

Who can use this feature?
  • Administrators and Technicians with the Client Portal Application Security Role setting, Modify Article Templates, ​​​​​can create and manage Knowledge Base templates and categories.
  • Article templates and template categories are managed from the Client Portal Knowledge Base.
  • Article templates can be used in all articles in the same Knowledge Base application.

Knowledge Base article templates are HTML formats that you can save and easily use in articles, helping to maintain consistent formatting and layout throughout your content. All formatted content within the system goes through HTML sanitization to ensure security and data integrity. These article templates support Bootstrap, which allows for HTML and CSS design templates that include typography, forms, buttons, navigation, and other interface components, along with optional JavaScript extensions.

Learn more about automated content sanitization
Learn more about using Bootstrap.

In this article, we'll cover:

Using Templates in the Editor

Users with access to create or edit articles can use templates. The templates menu appears on the editor toolbar. From this menu, you can select a template from the list, and it will insert the template content at the current cursor position without removing any existing text.

Defining a Template

To be able to define article templates, the user's application-level Security Role must be assigned the Modify Article Templates permission.

To add a template:

  1. In the Client Portal, go to the Knowledge Base.
  2. Select Templates in the top navigation.
  3. On the Templates page, click the +New Template button. 
  4. Select a Category for the template. This will group the templates in the Template dropdown list.
    • If no Categories have been added, click the button at the right side of the field to add a new Category
  5. Enter a Name for the template.
  6. Enter a Description to provide information to users when they hover over a template name in the editor.
  7. In the Body field, define the template's content. You can use the formatting tools in the editor or click the Source button to directly edit the HTML or add Bootstrap elements
  8. Click the Save button. 

Creating Template Categories

To be able to manage template categories in the Client Portal, the user's application-level Security Role must be assigned the Modify Article Templates permission.

Categories organize templates in the Templates dropdown menu. When creating categories, consider how article authors will utilize them.

To add a template category:

  1. In the Client Portal, go to the Knowledge Base.
  2. Select Templates in the top navigation.
  3. On the Templates page, click the Manage Categories button. 
  4. Click the + New Category button.
  5. Enter a category Name that can be used to group templates by type or purpose. 
  6. Enter a Description that will appear in the Manage Categories list.
  7. Click Save.

Template Samples

Templates can be used as a shortcut to including relevant formatting or to create a structure for the entire article.

Note that all the example templates end with the HTML for a new paragraph. This feature is included because it enables you to click below the template and start typing unformatted text outside of the template's content. 

<p>&nbsp;</p>

 

Bootstrap Alert Message 

This template will add a Bootstrap alert to the article, which can be used to call attention to important content. 

Template HTML

<div class="alert alert-danger" role="alert">Content goes here</div><p>&nbsp;</p>
<div class="alert alert-warning" role="alert">Content goes here</div><p>&nbsp;</p>
<div class="alert alert-info" role="alert">Content goes here</div><p>&nbsp;</p>

Content Display

 

Internal Instructions

This template provides an area designed for a link to internal documentation to be used on a public article. Authors will be trained to add the template, then double-click the “this article" text to bring up the hyperlink editor and easily add a linked article inline in the text. 

Template HTML

<div class="table-responsive">
<table class="table table-bordered" style="width: 100%;background-color:#f2f2f2">
  <tbody>
    <tr>
      <td>
      <h3>Helpdesk Consultants Only</h3>
      <p>Follow the instructions in <a href="https://www.teamdynamix.com">this article</a>.</p>
      </td>
    </tr>
  </tbody>
</table>
</div>
<p>&nbsp;</p>

Content Display

Helpdesk Consultants Only

Follow the instructions in this article.

 

Knowledge-Centered Service (KCS) Article

This template is an example of a very simple KCS article shell. Depending on the types of articles you have, you may define one or many article format templates. 

Template HTML

<h2>Issue</h2>
<p>&nbsp;</p>
<h2>Environment</h2>
<p>This article applies to&nbsp;</p>
<h2>Resolution</h2>
<p>&nbsp;</p>
<h2>Cause</h2>
<p>&nbsp;</p>

Content Display

Issue

 

Environment

This article applies to 

Resolution

 

Cause

 

Clickable Buttons

This template creates a clickable button that can be used to link to another area of the client portal or an external site. Once inserted, you can double-click the text to edit the hyperlink and double-click the icon to edit the icon.

Template HTML

<div class="row" style="margin: 5px"><a class="btn btn-primary btn-lg btn-block" href="http://status.teamdynamix.com/" target="_blank" title="TeamDynamix Systems Status"><span tabindex="-1"><span class="fa-solid fa-ambulance fa-fw"></span></span>TDX Systems Status</a></div>

Content Display

 

Collapsible Panel

This template creates a collapsible panel that can be toggled open or closed with a checkbox button. Once inserted, you can edit the title of the panel and add content that you want to hide/show inside the panel.

Template HTML

<div class="panel panel-default">
<div class="panel-heading" data-target=".Switch1" data-toggle="collapse">
<strong>Panel Title<label class="pull-right btn fa-solid fa-up-right-and-down-left-from-center" type="button"> 
</label>
</strong>
</div>

<div aria-expanded="true" class="panel panel-body Switch1 collapse in" style="">
<p>Content goes here</p>
</div>
</div>
<p>&nbsp;</p>

Content Display

Panel Title

Details

Details

Article ID: 62598
Created
Wed 9/19/18 5:13 PM
Modified
Wed 8/27/25 4:37 PM

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