Article and Service Templates

This how-to article will help TeamDynamix Administrators and Client Portal Application Administrators to create Service Catalog and Knowledge Base article templates. The user must have two settings enabled within the Client Portal Application Security Role: Modify Article Templates, Modify Service Templates

Overview

Knowledge base article and service catalog description templates are a set of HTML content that you can save, then easily add to articles or service definitions to facilitate consistent formatting and layout across services and articles. This article describes how to set up and use templates in both areas. Article templates and service description templates are two separate lists, which are not shared between applications. 

Article and service templates are subject to the same HTML allowlists and sanitization as articles and services, for more details see the related articles.

Using Templates

Anyone who can create or edit an article or service can access the templates that have been defined. The templates menu will display on the editor toolbar. Within it, you can choose a template from the list, and it will add the template's content wherever your cursor is, without replacing any other text. 

Defining a Template

To be able to define templates in the client portal, you must be assigned the Modify Article Templates and/or Modify Service Templates permission in TDAdmin.

To add templates and template categories:

  1. In the Client Portal, go to the Knowledge Base or Service Catalog.
    • The Templates for Service Catalog can be used for the new Service Offerings effective in version 11.3
  2. Select the Templates page in the bottom navigation bar. A list of existing templates will display. 
  3. Click the +New Template button to define a template. 
  4. Select a Category for the template.
    • This will display as the header in the Templates menu.
    • If no Categories have been added, click the +New button to add a new Category
    • Think about the categories in terms of how article and service authors will use them. 
  5. Enter a Name for the template.
  6. Enter a Description if you’d like. This will be available as part of the tooltip when hovering over a template in the templates menu. 
  7. In the Body field, define the template's content. You can use the formatting tools in the editor or click the Source button to directly edit the HTML. 
  8. Click the Save button. 

Template Examples

Templates can be used as a shortcut to including relevant formatting or to create a structure for the entire article or service.

Note that all the example templates end with the HTML for a new paragraph. This is included because it allows you to click below the template and start typing with unformatted text outside of the template's content. 

<p>&nbsp;</p>

 

Bootstrap Alert Message 

This template will add a Bootstrap alert to the article or service, which can be used to call out attention to important content. 

Template HTML

<div class="alert alert-danger" role="alert">Content goes here</div><p>&nbsp;</p>
<div class="alert alert-warning" role="alert">Content goes here</div><p>&nbsp;</p>
<div class="alert alert-info" role="alert">Content goes here</div><p>&nbsp;</p>

Content Display

 

Internal Instructions

This template provides an area designed for a link to internal documentation to be used on a public article. Authors will be trained to add the template, then double-click the “this article" text to bring up the hyperlink editor and easily add a linked article inline in the text. 

Template HTML

<div class="table-responsive">
<table class="table table-bordered" style="width: 100%;background-color:#f2f2f2">
  <tbody>
    <tr>
      <td>
      <h3>Helpdesk Consultants Only</h3>
      <p>Follow the instructions in <a href="https://www.teamdynamix.com">this article</a>.</p>
      </td>
    </tr>
  </tbody>
</table>
</div>
<p>&nbsp;</p>

Content Display

Helpdesk Consultants Only

Follow the instructions in this article.

 

Knowledge-Centered Service (KCS) Article

This template is an example of a very simple KCS article shell. Depending on the types of articles you have, you may define one or many article format templates. 

Template HTML

<h2>Issue</h2>
<p>&nbsp;</p>
<h2>Environment</h2>
<p>This article applies to&nbsp;</p>
<h2>Resolution</h2>
<p>&nbsp;</p>
<h2>Cause</h2>
<p>&nbsp;</p>

Content Display

Issue

 

Environment

This article applies to 

Resolution

 

Cause

 

Clickable Buttons

This template creates a clickable button which can be used to link to another area of the client portal or an external site. Once inserted, you can double-click the text to edit the hyperlink and double-click the icon to edit the icon.

Template HTML

<div class="row" style="margin: 5px"><a class="btn btn-primary btn-lg btn-block" href="http://status.teamdynamix.com/" target="_blank" title="TeamDynamix Systems Status"><span tabindex="-1"><span class="fa fa-ambulance fa-fw"></span></span>TDX Systems Status</a></div>

Content Display

 

Collapsible Panel

This template creates a collapsible panel that can be toggled open or closed with a checkbox button. Once inserted, you can edit the title of the panel and add content that you want to hide/show inside the panel.

Template HTML

<div class="panel panel-default">
<div class="panel-heading" data-target=".Switch1" data-toggle="collapse">
<strong>Panel Title<label class="pull-right btn fa fa-expand" type="button"> </label></strong></div>

<div aria-expanded="true" class="panel panel-body Switch1 collapse in" style="">
<p>Content goes here</p>
</div>
</div>
<p>&nbsp;</p>

Content Display

Panel Title

Content goes here

 

Examples

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Details

Article ID: 62598
Created
Wed 9/19/18 5:13 PM
Modified
Mon 2/26/24 5:55 PM

Related Articles (2)

This getting started article will help Administrators to build a Service Catalog using the TDClient and TDAdmin interfaces.
This introduction article will help to TeamDynamix Administrators, Service Catalog managers, and Knowledge Base managers to build HTML content using the TDClient interface.